Error en Programador CH341a : «Chip Main Memory are not null»

El colega Dario, perteneciente a un grupo de expertos en la materia Netbook/Notebook, nos informa una solución al famoso mensaje de error emitido por el Software CH341a al momento de grabar nuestra memoria.

 

Al momento de re-programar una bios ,en este caso «W25Q64FW» (1.8v) en formato SOIC 8, como parte del proceso de reparacion de una Netbook G5 entregada por el Gobierno Argentino, suele aparecernos un mensaje como el siguiente:

 

Como podremos ver en la imagen, la memoria con su identificador : D86380654B3B7622 … falló en su proceso de grabación.

Hasta donde sabíamos, el error era un claro indicador de una falla grave… la memoria en este caso de la firma Winbond modelo W25Q64FW no podia ser grabada con el binario que desrabamos, sospechando en primer lugar que la memoria se había quemado.

Con una pequeña modificación en el circuito podremos ahorrarnos bastante dinero e incluso podremos rescatar esas «memorias quemadas» que tenemos tiradas por ahí en algún rincón de nuestro taller.

¿Que debemos hacer?

Muy sencillo, al momento de programar utilizaremos el «Metodo del PIN 8» el cual consiste en levantar el PIN 8, o PATA 8 del programador al momento de realizar la reprogramacion de la memoria. Podemos quitar el cable de la pinza o simplemente colocando una cinta aislante electrica o de papel sobre el PIN 8 de la memoria para aislarlo y evitar el contacto.

Veremos aquí unas imágenes de ejemplo:

 

Una vez hecho esto si todo salio bien obtendremos el siguiente resultado:

 

Si observamos con detenimiento las imágenes,  ya sea tanto en la imagen donde nos apareció el error, como en la ultima imagen con la grabación exitosa, veremos que el ID del chip (el identificador único e irrepetible para cada chip) «D86380654B3B7622» sigue siendo el mismo.

Lo que demuestra que un chip que dábamos por muerto pudo volver a la vida con este sencillo artilujio.

Muchas gracias Dario

 

Preguntas Frecuentes:

 

Efectivamente,  el «metodo del PIN 8» que vimos en el post, nos brinda como beneficio adicional poder reprogramar estas Memoria SPI , BIOS e incluso EC, sin tener que ser extraída de la placa.

 

 

Load More

¿Te ha sido util este post? Comenta debajo…

 

 

392 comentarios sobre “Error en Programador CH341a : «Chip Main Memory are not null»”

  1. Hola buenas tardes gente
    Consulto si alguien tiene el bios de una positivo bgh g680 placa nh4cuxx 6l m/b rev.1.0 la cual me enciende sin video quiero probar eso tiene todas tensiones normales. muchas gracias. saludos

  2. Buenas tardes. Tengo un problema con las WEBCAM de las net g5 (creo que también pasa con la g6) del gobierno.

    Programo la bios como siempre. Cuando la armo me sale el problema de las luces intermintentes(violeta y azul).

    Hago TODO el procedimiento para solucionar ese problema y todo sale bien.

    La armo, la enciendo y el windows corre perfecto excepto la WEBCAM. Pensé que era un problema de drivers y no. Instalo el windows y nada. Como el dueño no usa la webcan me dice que no hay problema.
    Ahora me pasó exactamente lo mismo con otra.
    Me la trajerón porque le quedaban pocos arranques así que revisé la cámara y andaba BIEN. Seguramente me pasó lo mismo antes pero yo jamás me enteré xq no revisé la cárma(!!!) UN PAPELÓN!
    Yo siempre saco la bios porque la pinza ya no agarra. No creo que tenga algo que ver pero es un dato.El programador es el CH341A y anda bien.

    Creo que se trata de un problema de los binarios. AYUDA!!

    1. Buenas noches utiliza la última versión de los binarios la 1.04 y con solo grabar el de la BIOS ya deberías desbloquear la notebook.
      Y con este binario no he tenido problemas del hardware.
      Saludos.

      1. Gracias por responder. Cuando salieron esos binarios. Yo tengo un montón que descargue da acá y otros foros.
        Me pasas un link o decime cómo los busco.
        Gracias. Disculpa tanta molestia.

        1. Buen día los buscas en esta página y ahí haces click en el enlace que si mal no recuerdo es de Google drive.
          Saludos.

    2. Hola Marcelo, y colega Angel, como estan, me sucedio una vez, pero no me acuerdo como lo solucione, mala mia que no lo comente, yo me inclinaria a que es un problema de Drivers, probaste marcelo instarla Driver booster o alguno similar, o bien puedes googlear el driver buscando el id de hardware de la camara.

      1. Hola. Cristian. Buenas tardes.
        Si. Soy técnico. Probé de todo. Yo tengo backup de drivers de todas las nets. Que es lo más confiable y no funcionó.
        Probé los oficiales y varios programas. Los que uso siempre o otros más y nada.
        Probé con otra webcam xq al principio creí que era eso e instalé su driver.
        Y nada.

        Cuál es el método que utilizas en el caso de las luces del intermitentes?
        Yo hago todo fuera de la net porque la pinza no tiene agarre.
        Siempre hablando de Netbook del gobierno.
        Si me pasas tus binarios me harías un gran favor.
        Yo tengo montones que bajé y compré y ya no sé en cual confiar.

        Gracias por responder.

  3. Hola quisiera saber si alguien me puede ayudar con el siguiente problema, tengo dos netbook G7 o G9 SF20BA 2.0 que al flashear la memoria bios con los binarios descargados de este mismo sitio, ambas netbook no encienden es decir al prenderla la pantalla parpadea no da video y es un siclo infinito. Ya probé con varios binarios pero el resultado es el mismo lo raro es que la memoria bios original al colocarla en el programador este no la detecta como si no anduviera pero al colocarla sin modificarla la notebook vuelve a encender pero bloqueada. Intente cambiar la memoria bios reprogramarla pero el resultado sigue siendo el mismo.

    1. Buenas tardes mira la mayoría de las personas que tuvieron este problema, lo solucionaron grabando el chip del Bios sin la pata 4 en contacto con el programador (siempre con el chip afuera de la placa y con el adaptador de 1.8v correspondiente) y recién sueldas el chip a la placa.
      Sinceramente no lo probé de esta manera, pero veo que muchos dieron solución de esta manera al problema de que no da video una vez programado el chip de otra manera.
      Proba y comenta.
      Saludos.

  4. Hola amigos tenho el digente problema estoy tratando de grabar un chip bios con ch341 con las pinzas y me sale este mensaje wite oprratios timeout failed, ayuda porfavor

  5. Buenas Noches, tengo la pinza conectada a una 25Q16BVSIG, pero el programador no lee nada, es como si estuviese en blanco. Sé de antemano que ésto no es así porque tengo tres pc y pasa lo mismo. Veo que en mi programador hay un puente entre los pines 1 y 2 que trae a los costados del zócalo y que así vino desde que lo compré. Aparentemente algo no se comunica. Será error de controladores, o como dicen, es necesario bloquear la pata 8? En último caso desoldar completamente y reprogramar fuera? También leí soldar patas 20 y 21 de otro IC. Alguien podría ayudarme con ésto? Desde ya, Infinitas Gracias…

  6. Buenas desde España,…es posible aplicar el metodo de la cinta para flashear una bios de una placa funcional en otra que no lo hace y que esta brickeada???. una idea se podria poner un interruptor en el cable nº 8, para cuando leemos poner el circuito cerrado y cuando grabamos ponerlo en abierto y asi cortar la patilla nº8 sin tener que poner la cinta aislante?.Gracias!!!!

  7. Hola gente como me solucionaron la otra vez el drama y aprendí. Ahora tengo otro tenía 3 G4 positivo bgh para reprogramar regrabe 2 y salieron andando. Y la tercera no quiso prender más! Ni enciende ni carga nada. Y andaba. Y hoy mismo me llegó otra que enciende pero no da vídeo nada. Soluciones acudo a ustedes la «unión de técnicos unidos» saludos a todos desde cba!!!

    1. Buen día si sacaste la bios para programarla afuera, por experiencia propia, primero debes verificar que las soldaduras de las patas del chip estén bien, repásalas un poco y proba.
      Sino me ha pasado por experiencia propia que al sacar la bios, se corre o se sale directamente una resistencia que se encuentra al lado del chip, y era eso por lo que no iniciaba nada, comproba con otra placa si las resistencias están correctas.
      Lo otro seria sacar el TPM y la resistencia R370.
      Saludos.

      1. Hola Waldemar y camaradas, me ayudan. me traen una net 3g CDR(coradir) le reprogramo la Bios con la pinza y le cambio la pila, todo bien hasta ahi pero cuando la enchufo no enciende, probé con colocarle la bateria y tampoco. Al parecer pasa corriente a la placa. intente sacar la Bios y flashearla afuera y salio bien la programación pero igual no enciende.qué puede ser? lei algo de la resistencia pero nose de que se trata. Help!!

          1. Hola Waldemar, antes que nada quiero agradecerte por tomar tu tiempo para responderme tan rapido!!. Comparto mi experiencia: Hice lo que me recomendaste de quitar el tpm y demás pero seguía sin encender pensé que había quemado la placa hasta que probé la placa en otra netbook y arrancaba lo mas bien entonces vi que el problema estaba en la plaqueta que se encuentra en el sector de encendido, por alguna razón se daño y no pasaba corriente a la placa madre. Conclusión solo tuve que reemplazar esa plaquita, pero eso de quitar el TPM no lo sabia, muchas gracias, un trabajo tiene una gran recompensa!! espero que la tengas. Saludos

            1. Es broma en serio quitando el TPM y la resistencia la G3 queda liberada!!???? Me caigo y me levanto. No posta no es que sin TPM no enciende la Netbook????

  8. Hola buenas tardes, quería comentar que ya trate de varias formar reprogramar un chips winbond W25Q80BV el cual tiene número unique id C869D4730F562E35, el cual me deja borrarlo y programarlo pero al iniciar la netbook sigue bloqueada, la netbook es una EXO X355

    1. Buenas tardes, lo vuelvo a repetir por enésima vez, las G1, G2 y las G3, no se desbloquean solo con programar el bios, hay que hacer el puente temporal en el TPM (pata 21 y 22), para que se libere.
      Sino lo mas efectivo es sacar el TPM, y ya deberían quedar desbloqueadas las G1 y las G2, en las G3 además hay que sacar la resistencia R180.
      Saludos.

  9. Bendita sea la madre que te parió, el Macbook pro que estoy arreglando usa unos sin patas, con los contactos por debajo, he cortado la traza en la placa adaptadora del programador donde se suelda.

  10. Hola, buenas tardes. Tengo una G5 lo cual reprograme el EC por falla de luz violeta. El tema es que ahora no da señal de vida, por mas que enchufe el cargador ni siquiera prende la luz de carga ni al darle al botón de encendido. Eh intentado volver a ponerle el mismo bin defectuoso al EC y al bios lo volví a poner como tal cual estaba pero sigue igual, no da señal de vida. Me podrían brindar información sobre si alguno le paso y como lo solucionaron. Gracias

    1. amigo estoy en las mismas que vos ,,le reescribi el backup que le hice antes de reescribir y nada.esta muerta ,,voy a tener que comprar bios y ec reprogramados en mercado libre para probar..ah y por sierto al dar verify en el programa me sale el error ´La memoria principal del chip con el contenido está en desacuerdo´ por eso mismo llegue aqui ..voy a seguir buscando info si sabes de algo me avisas porfa

      1. amigos!!!!!!!!! lo solucione lo que tienen que hacer es sacar el bios para reprogramar.en mi caso tuve que sacar el bios y el ec para reprogramarlos fuera de placa y volver a soldarlos quedaron joya…tengan en cuenta que despues de escribir el bin modificado a ambos bios tienen que dar en «verify»si les sale que los archivos estan en desacuerdo es porque estan flasheando en la bios sin desoldar …al reprogramar ambos fuera de placa no me saltaba este error pasaba bien el verify y efectivamente prendio .reitero que estaba totalmente muerta la net..lo primero que recibe voltaje al presionar encendido es el chip ec a la pata 8 le lleva 3.2 volts testeen eso tambien

        1. hola daniel, tengo el mismo problema….tengo 2 net gene 6 revision 2 muertas… mi pregunta es si tengo que comprar el adaptador 200.000 mil y el adaptador 150.000 mil para el EC..acabo de comprar nuevamente pinzas.. pero tampoco resulta….agradeceria tu opinion.gracias.

          1. amigo yo saque la bios y ec para reprogramar .no con la pinza …lo solde a uno de los adaptadores que te trae el ch341a https://articulo.mercadolibre.com.ar/MLA-645362344-pinza-soic-8-pin-notebook-net-flash-bios-ic-24-25-_JM#reco_item_pos=2&reco_backend=machinalis-domain-pads&reco_backend_type=low_level&reco_client=vip-pads&reco_id=439dd633-0988-4b41-97f6-1e7266731281&is_advertising=true&ad_domain=VIPCORE_RECOMMENDED&ad_position=3&ad_click_id=Yjk0NWNlNjgtMjVmMS00N2NhLWE4NDUtNmJlMWM2YTkxODk2 a la plaqueta esa y todo salio ok .no probé con la pinza para reprogramar fuera lo veía inseguro ..pero supongo que deberia funcar igual.la placa no tiene ninguna resistencia al igual que la pinza.

          2. https://www.mediafire.com/file/gciy2ju5am1439d/binarios_conectar_igualdad_v2.0%255BESTOICO_SHOP%255Ddefinitivo.rar/file aqui estan los archivos que uso para desbloquear cualquier net,lo consegui en mercado libre y lo resubi free para todos tanbien estan los archivos con el que solucione el problema de las luces que en un principio flashee pero la net quedo muerta por completo…como dije la solucion es sacar tanto el bios como el ec y reprogramarlos fuera de placa .estando fuera de la mother lo reprograman con el adaptador de bios en la plaquetita va soldada https://articulo.mercadolibre.com.ar/MLA-645362344-pinza-soic-8-pin-notebook-net-flash-bios-ic-24-25-_JM#reco_item_pos=2&reco_backend=machinalis-domain-pads&reco_backend_type=low_level&reco_client=vip-pads&reco_id=439dd633-0988-4b41-97f6-1e7266731281&is_advertising=true&ad_domain=VIPCORE_RECOMMENDED&ad_position=3&ad_click_id=Yjk0NWNlNjgtMjVmMS00N2NhLWE4NDUtNmJlMWM2YTkxODk no posee resistencias ni nada haci que si quieren tambien pueden usar las pinzas deberia ser lo mismo en teoria..yo lo hago con la plaquetita por ser mas seguro que las pinzas

        2. Hola colegas, les comento que me pasa lo mismo, tengo una placa de net G5 que reprograme la bios y ec fuera de la placa, tapando la pata 8 en ambos pero al probarla en la net no enciendo nada ni luces nada de nada. ya lo intenté 2 veces la reprogramación de la bios pero sigue sin dar señal de vida. Saben como solucionarlo?

          1. Buen día utiliza la ultima version del binario que es la 1.04 (Bios y EC), y programas la Bios solamente, y con esto ya se debería desbloquear; sino, si sale algún error de luces u otro, recién programas el EC.
            Asumo que sacas el chip y lo programas afuera con sus respectivos adaptadores para el BIOS, y para los 1.8v que tienen estos chips, ya que de esta manera no tenes que tapar ninguna pata y la grabación se realiza sin errores (como ya sabrás los de las famosas pinzas personalmente las detesto).
            Saludos.

      2. yo lo solucione de la siguiente manera. programo la bios con la bateria desconectada y la IC sin desoldar de la mother, con la bateria desconectada. Y funciono perfecto con la G5

  11. Hola como estas? Tengo una Netbook g4 CDR, reprogramé el chip con el binario que use siempre para este modelo y ahora la PC no me da video. ¿Tendrás alguna solución?

    1. hola solucionaste el desbloqueo a mi me aconsejaron regrabarlo con bios afuera de la placa otro sacarle la pila pero sigue sin prender yo desbloquee otra sacando tpm y resistencia esa funciono

  12. Hola Cristian.
    Tengo el chip Winbond 25Q80BVSIG 1314 (1,8v) en una placa base MSI G41M P33 Combo y no logro reprogramarla con el CH341A, ni con el software CH341A Programmer ni con AsProgrammer.
    Lo del pin 8 lo he probado y no logro solucionarlo. No detecta el chip y no lo programa ¿podrías informarme como se hace exactamente? ¿en qué momento he de conectarlo sin el pin 8?
    Gracias anticipadas.

    1. Hola buen día el chip Winbond 25Q80BV no es de 1.8v, y si funciona de 2.7v a 3.6v, salvo que te hayas equivocado al escribirlo y tengas el 25Q80EW que este si es de 1.8v.
      Además, en los programadores figuran las dos nomenclaturas; como siempre recomiendo sacar los chips y programarlos afuera, nada de pinzas y esas yerbas, y utilizar el adaptador de 1.8v cuando los chips sean de este voltaje, sin tapar patas ni nada, ya que así se evitan los errores de detección y su posterior grabado.
      Espero que te sirva esta información.

Deja un comentario aqui